Dyndns läuft nicht

  • Hallo!


    Ich bekomme leider auf meiner Endianfirewall den Dyndns dienst nicht zum laufen. Habe schon wie im Forum geschrieben
    den bugfix ausgeführt. Leider ohne Erfolg. Was mache ich falsch?


    Vielen Dank für eure Hilfe

  • Guten Morgen,
    was genau geht den nicht?
    Gibt es Meldungen in irgend einem log?


    Daten korrekt eingetragen?
    Mal probiert in der Console /SSH den DDNS Updater zu starten?


    gruß wolf

    Mein Computer kann alles, wegen seiner 32 Bit!
    Wenn ich 32 Bit intus habe, kann ich auch alles!

  • Guten Morgen!


    Die Ip Adresse wird einfacht nicht upgedatet. Die Daten sind korrekt. Sind so auf
    dem Dyndns Updater eingetragen der auf dem Server ohne Probleme läuft. Wollte diesen nur ersetzen.
    Wie kann ich über ssh den DDNS Updater starten?


    In welchen Logs sollte ich da nachschauen? Bin Endianneuling habe vorher mit Ipcop gearbeitet also sorry für die
    blöden fragen.


    Veieln Dank für eure Mühe

  • Quote from "Daniel"

    In welchen Logs sollte ich da nachschauen?


    Unter /var/log/messages sollte sich dieser Eintrag befinden:


    sudo: nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/local/bin/setddns.pl -f 2


    Welche Version nutzt Du? In der 2.4.1 gibt es einen Bug in der Datei /usr/local/bin/setddns.pl
    Dort die Zeile
    if ($settings{'SERVICE'} = 'zoneedit')
    ersetzen durch
    if ($settings{'SERVICE'} eq 'zoneedit')


    Danach in der Weboberfläche ein Update durchführen, dann sollte es passen.



    Gruß
    Joachim

  • Hallo Meisen!


    Diese Zeile hatte ich schon aufgrund eines Tipps im Forum geändert.


    In der Logdatei steht nichts von dieser Zeile. Was läuft hier falsch?


    Vielen dank an alle Helfer
    Daniel

  • Hallo zusammen,


    bei mir besteht ebenfalls ein Problem in Verbindung mit DynDNS und der EndianFirewall community Version 2.4.1...
    Ich habe den Dienst unter "Dynamischer DNS" ganz normal mit den Benutzerkennungen + Daten von dyndns.org eingerichtet, aber leider wird die IP-Adresse nicht aktualisiert, sprich: ich update die IP auf dyndns.com manuell und schon ist der Server über die eingerichtete domain und über die EFW erreichbar.
    Sobald aber die IP-Adresse autom. nach 24h gewechselt wird, ist der DynDNS-Dienst nicht mehr erreichbar, weil EFW die IP nicht aktualisiert.
    Die Änderung in der Datei /usr/local/bin/setddns.pl
    Dort die Zeile
    if ($settings{'SERVICE'} = 'zoneedit')
    ersetzen durch
    if ($settings{'SERVICE'} eq 'zoneedit')
    habe ich auch bereits vorgenommen, leider ohne Erfolg!


    Weiß jemand einen Rat, bzw. wo dort der Fehler liegt?


    Gruß

  • Hallo,
    Schau mal hier: Angeblich sollte es dann Funktioniern ? ?


    http://bugs.endian.com/view.php?id=3307



    Es ist ein Fehler in der Datei /usr/local/bin/setddns.pl.
    ca. Zeile 387


    Bitte ersetzen Sie die folgende if-Anweisung:


    if ($settings{'SERVICE'} = 'zoneedit')
    {$serverdir = '-s'; $serveradd = 'dynamic.zoneedit.com';}
    else
    {$serverdir = ''; $serveradd = '';}


    Mit dieser:


    if ($settings{'SERVICE'} eq 'zoneedit')
    {$serverdir = '-s'; $serveradd = 'dynamic.zoneedit.com';}
    else
    {$serverdir = ''; $serveradd = '';}



    Gruß Sabine

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final

  • Oh, ich sehe gerade das hat Meisen ja auch schon geschrieben !


    Laut Endian Entwickler soll es danach gehen und wohl genauso im nächsten Update so kommen . . . . . . . . . .


    Gruß Sabine

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final

  • Hallo Sabine,


    es läuft jetzt, ich hatte noch einen Falsch-Eintrag unter "*Domain" stehen :nerv:


    An alle, die Probleme bei der Einrichtung haben:


    1.Bugfix durchführen:
    if ($settings{'SERVICE'} eq 'zoneedit')
    {$serverdir = '-s'; $serveradd = 'dynamic.zoneedit.com';}
    else
    {$serverdir = ''; $serveradd = '';}



    2. neuen Host unter "Dynamischer DNS" hinzufügen:


    Dienst: dyndns.org ; hostname: mein-hostname ; Domain: dyndns.org ; Benutzername: user1 ; Passwort: passwort


    und alles funktioniert ;)