Verbindungsabbrüche ohne nennenswerte Hinweise im Log

  • Hallo zusammen,


    seit einiger Zeit bricht bei uns mehrfach am Tag aber unregelmäßig die Verbindung zum Internet ab - ohne dass das Internet eigentlich gestört wäre. Unser Netzwrk besteht aus zwei Ringen. Das äußere Netzwerk / DMZ hat WLAN und einen Lancom DSL Router und sonstige Services. Die Endian trennt den inneren Ring vom äußeren, hierzu wird der Router als Static Gateway verwendet, d.h. NATing, kein Routing.


    Von Zeit zu Zeit kommt es vor, das einige Sekunden bis 1-3 Minuten die Verbindung ins Internet weg ist. Ein Ping auf 8.8.8.8 und ein weiterer auf die Endian zeigt, dass die FW weiter erreichbar ist jedoch kein Internetverkehr mehr möglich ist. Von WLAN Geräten, welche im äußeren Ring sind, kann das Internet weiter ohne Ausfall während dessen erreicht werden.


    Ein Kollege hat mir mitgeteilt, dass ihm aufgefallen wäre, dass die Endian im Serverraum dabei gelegentlich piept, also als wenn bspw. ein Link hergestellt wird (Kabel rein, Kabel raus?). Switche sind bereits vom Strom genommen worden, DSL Router ausgetauscht, Endian auf anderer Hardware installiert + Config wieder hergestellt, Kabel ausgetauscht. Das einziege was ich im Log (...wenn auch gefühlt nicht oft genug im Vergleich zu den geführen Ausfällen ) sehe sind Link up und Link down - aber nicht warum das passiert.


    Hat hier ggf. jemand noch ne Idee oder einen konreten Hinweis in welches Log in der Endian / Shell ich gucken kann um dem auf den Grund zu kommen?


    Dank + Gruß,


    Tom

  • Wie es der Zufall will gucke ich grad nochmal in die Logs und sehe das hier, jemand ne Idee was das verursachen kann? Wo kommt der "uplink stop main" her?


    May 22 15:47:19 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/postqueue -f

    May 22 15:47:16 dnsmasq[6203] using nameserver 8.8.4.4#53

    May 22 15:47:16 dnsmasq[6203] using nameserver 8.8.8.8#53

    May 22 15:47:16 dnsmasq[6203] reading /etc/dnsmasq/resolv.conf

    May 22 15:47:12 dnsmasq[6203] using nameserver 8.8.4.4#53

    May 22 15:47:12 dnsmasq[6203] using nameserver 8.8.8.8#53

    May 22 15:47:12 dnsmasq[6203] reading /etc/dnsmasq/resolv.conf

    May 22 15:46:37 kernel r8169 0000:04:00.0 eth3: link up

    May 22 15:46:36 ntpd[3164] new interface(s) found: waking up resolver

    May 22 15:46:36 ntpd[3164] Listen normally on 6 eth3 192.168.13.26:123

    May 22 15:46:36 dnsmasq[6203] using nameserver 8.8.4.4#53

    May 22 15:46:36 dnsmasq[6203] using nameserver 8.8.8.8#53

    May 22 15:46:36 dnsmasq[6203] reading /etc/dnsmasq/resolv.conf

    May 22 15:46:35 uplink[main] Uplink 'main' status: 'ONLINE'

    May 22 15:46:35 uplink[main] Notify uplinks daemon about status change of uplink 'main'. Status id OK

    May 22 15:46:35 kernel r8169 0000:04:00.0 eth3: link down

    May 22 15:46:34 uplink[main] Starting Uplink 'main'

    May 22 15:46:34 ntpd[3164] 31.172.86.173 local addr 192.168.13.26 ->

    May 22 15:46:34 ntpd[3164] 176.221.42.125 local addr 192.168.13.26 ->

    May 22 15:46:34 ntpd[3164] 176.9.102.215 local addr 192.168.13.26 ->

    May 22 15:46:34 ntpd[3164] 51.254.155.97 local addr 192.168.13.26 ->

    May 22 15:46:34 ntpd[3164] Deleting interface #5 eth3, 192.168.13.26#123, interface stats: received=225, sent=236, dropped=0, active_time=18199 secs

    May 22 15:46:33 uplink[main] Successfully shut down link 'main'

    May 22 15:46:33 uplink[main] Uplink 'main' status: 'OFFLINE'

    May 22 15:46:33 uplink[main] Notify uplinks daemon about status change of uplink 'main'. Status id FAILED

    May 22 15:46:33 kernel r8169 0000:04:00.0 eth3: link down

    May 22 15:46:33 kernel r8169 0000:04:00.0 eth3: link down

    May 22 15:46:32 uplink[main] Stopping Uplink 'main'

    May 22 15:46:30 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/etc/rc.d/uplinks stop main

    May 22 15:46:30 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:45:36 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:45:33 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/bin/openvpn-user list

    May 22 15:45:33 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:45:26 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/bin/openvpn-user list

    May 22 15:43:52 fcron[16839] Job [ -x /bin/run-parts ] && run-parts --report /etc/anacron.hourly completed

    May 22 15:43:44 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:43:40 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/bin/openvpn-user list

    May 22 15:43:40 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:43:36 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:43:33 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:43:30 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:43:25 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/bin/openvpn-user list

    May 22 15:43:25 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:43:18 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/bin/openvpn-user list

    May 22 15:43:18 sudo nobody : TTY=unknown ; PWD=/home/httpd/cgi-bin ; USER=root ; COMMAND=/usr/sbin/ifplugstatus

    May 22 15:42:53 kernel device br0 left promiscuous mode

    May 22 15:42:47 fcron[16839] Job [ -x /bin/run-parts ] && run-parts --report /etc/anacron.hourly started for user root (pid 16840)

    May 22 15:42:39 httpd Use of qw(...) as parentheses is deprecated at /home/httpd/cgi-bin/salearn.cgi line 207.

    May 22 15:01:02 fcron[15946] Job [ -x /bin/run-parts ] && run-parts --report /etc/cron.hourly terminated (exit status: 1)

  • Hallo,


    May 22 15:46:33 kernel r8169 0000:04:00.0 eth3: link down

    May 22 15:46:33 kernel r8169 0000:04:00.0 eth3: link down


    Hängt hier das WAN dran?

    kabel defekt, Gerät kaputt?

    DSL Modem defekt oder zu warm?


    Der Uplinks Daemon -- also bei den WAN Schnittstellen, lässt du da einen Host prüfen ob er erreichbar ist?

    Möglich das der nicht vorhanden ist und dann die WAN Schnittstelle deaktiviert/neustartet

    Mein Computer kann alles, wegen seiner 32 Bit!
    Wenn ich 32 Bit intus habe, kann ich auch alles!

  • Hallo Wolfili,
    das alles kann ich ausschließen, da jegliche Komponente inkl. der Firewallhardware und Kabeln bereits getauscht wurde. allerdings muss ich sagen, dass der Teil des Logs auch nicht representativ für die Vorkommnisse sind. Allerdings habe ich jetzt ggf. etwas. Immer wenn die Verbindung für 4-8 Pings weg ist sehe ich dieses hier im Log:


    May 24 22:38:22 dnsmasq[2433] using nameserver 8.8.4.4#53

    May 24 22:38:22 dnsmasq[2433] using nameserver 8.8.8.8#53

    May 24 22:38:22 dnsmasq[2433] reading /etc/dnsmasq/resolv.conf

    May 24 22:38:19 dnsmasq[2433] using nameserver 8.8.4.4#53

    May 24 22:38:19 dnsmasq[2433] using nameserver 8.8.8.8#53

    May 24 22:38:19 dnsmasq[2433] reading /etc/dnsmasq/resolv.conf

    May 24 22:37:52 dnsmasq[2433] using nameserver 8.8.4.4#53

    May 24 22:37:52 dnsmasq[2433] using nameserver 8.8.8.8#53


    Hat jemand hierzu ggf. eine Idee? Ich sehe keinerlei ZUsammenhang in der Umgebung. Anbei hänge ich auch nochmal zwei Screenshots.


    wolfili

    ich lasse im Uplink die Erreichbarkeit von 8.8.8.8 testen. Allerdings passiert das hier mit und ohne dem Test. In der Tat ist eth3 der WAN uplink.


    Gruß,


    Tom