Upgrade Fehler

  • Hallo,
    beim Upgrade von 2.3 bekomme ich immer folgende Fehlermeldungen:



    Committing transaction...
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 6%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 15%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 45%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 48%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 54%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 60%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 66%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 69%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 72%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 84%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 90%)
    error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found ( 93%)
    Preparing... #################################################### [ 0%]
    error: package debianutils-2.13.2-0.endian0.i386 is already installed
    error: package perl-5.8.5-36.RHEL4.endian4.i586 is already installed
    error: package sysfsutils-1.2.0-1.endian1.i386 is already installed
    error: package clamav-0.96.3-1.endian9.i586 is already installed


    error: package python-2.4.6-18.endian7.i586 is already installed
    error: package curl-7.15.5-2.endian0.i386 is already installed
    error: package libnfnetlink-1.0.0-1.endian3.i586 is already installed
    error: package squid-radius-auth-1.07-1.endian1.i586 is already installed
    error: package openvpn-2.1.1-15.endian22.i586 is already installed
    error: package postgresql-libs-8.1.5-1PGDG.endian36.i586 is already installed
    error: package perl-URI-1.35-1.endian0.noarch is already installed
    error: package lm_sensors-3.0.0-2.endian6.i586 is already installed
    error: package python-netfilter_conntrack-0.4.2-0.endian1.i586 is already installed
    error: package pyzor-0.4.0-6.endian5.i386 is already installed
    error: package iptables-1.4.8-1.endian16.i586 is already installed
    error: package collectd-4.9.1-1.endian22.i586 is already installed
    error: package efw-firewall-2.4.7-24.endian25.noarch is already installed
    error: file /etc/rc.d/start/39uplinksdaemon from install of uplinksdaemon-2.3.5-0.endian14.i586 conf
    licts with file from package uplinksdaemon-2.3.2-0.endian13.i586
    error: file /usr/lib/python2.4/site-packages/uplinksdaemon-0.9.20-py2.4.egg-info/SOURCES.txt from in
    stall of uplinksdaemon-2.3.5-0.endian14.i586 conflicts with file from package uplinksdaemon-2.3.2-0.
    endian13.i586
    error: file /usr/lib/python2.4/site-packages/uplinksdaemon-0.9.20-py2.4.egg-info/top_level.txt from
    install of uplinksdaemon-2.3.5-0.endian14.i586 conflicts with file from package uplinksdaemon-2.3.2-
    0.endian13.i586


    Kann mir da jemand helfen ??

  • Moin,
    ja das hatte ich auch schon mehrfach !
    Am nächsten Tag ging es dann wieder.
    In welchen Abständen hast du versucht das Update zu machen ?


    Gruß sabine

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final

  • Ich sehe so eben das du die 2.3 hast, mit der gab es schon öfter Problem beim Updaten.
    Ich hatte das bisher erst bei der 2.2 die gar nicht wollte und ich dann die 2.4 installiert habe, da musste ich natürlich alle Regeln neu machen.
    Und auch da wollte eine nicht, also noch mal installieren.
    Wenn du nicht allzu viele Regeln hast würde ich die 2.4 installieren ( hier aus dem Forum ) und dann Updaten und die Regel neu machen.


    Hast du schon mal versucht alle Dienste auszuschalten ( Proxy, Firewall, Antivirus, Snort ) um dann das Update laufen zulassen ?


    Gruß Sabine

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final