Keine Verbindung zwischen Client und Außenstelle möglich

  • Hallo,


    wir haben seit längerem das Problem das VPN Clients sich nicht mit Außenstellen verbinden können, nachdem ich jetzt etliche Möglichkeiten probiert habe wollte ich mal im Forum nach Hilfe fragen.


    Folgender Aufbau ist aktuell vorhanden:

    Site A: OpenVPN-Server(Endian) mit eigenem VPN-Subnetz

    Site B: OpenVPN-Client (Endian) der mit Site A verbunden ist

    Site C: OpenVPN-Client (Endian) der mit Site A verbunden ist

    PC A: OpenVPN-Client 2.4.4 der mit Site A verbunden ist


    Folgendes Problem besteht:

    Von den Endian Außenstellen und auch dem Server kann ich alle Dienste erreichen egal wo sie sich befinden.

    Nur mit meinen PC kann ich lediglich Site A erreich, also der Server mit dem ich mit OpenVPN verbinde.

    Bei den Außenstellen kann ich zwar alles anpingen auch die Webserver etc. die hinten dran hängen aber alles andere klappt nicht.

    Der Versuch eine Website oder Endian auf Site B/C aufzurufen endet nach einiger Zeit mit einem Timeout.


    Bereits versuchte Lösungsansätze:


    VPN-Firewall auf allen Endian Installationen abgeschaltet

    Firewall auf allen Endian Installationen abgeschaltet

    Verschiedene OpenVPN-Client Configs auf meinem PC getestest.


    Ich weiss leider nicht was ich noch alles versuchen soll, das Routing scheint in Ordnung zu sein da ein Pingen ja möglich ist.

    Nur jeglicher anderer Traffic scheint nicht durchzukommen.

    Eventuell hat ja noch jemand einen Tip für mich was ich übersehen haben könnte.


    Edit:

    Alle Installationen sind jeweils auf dem aktuellsten Stand 3.2.4

    Meine aktuelle OpenVPN-Config habe ich als Anhang hinzugefügt (IP etc. wurden durch "x" ersetzt)


    Gruß Michael

  • Hallo,

    würde vermuten die VPN Firewall,

    aber die hast du ja lt. oben stehend, abgeschaltet.


    Ping geht raus, mach doch mal n tracert ob es auch da hin geht wo es hin gehen soll.

    Mein Computer kann alles, wegen seiner 32 Bit!
    Wenn ich 32 Bit intus habe, kann ich auch alles!

  • Hallo,


    sorry für die späte Rückmeldung bin eben erst dazu gekommen.

    Das wichtigste zuerst, das Problem ist nun endlich gelöst.

    Ein Tracert von meinem PC Zuhause auf den PC auf der Arbeit und umgedreht ist jeweils beim Server (A) hängengeblieben.

    Dank dir habe ich mir nochmal alle VPN-Einstellungen angesehen und konnte den Fehler beim VPN-Server finden.

    Unter erweiterte Einstellungen war bei "Client-zu-Client Verbindungen" aktuell "direkte Verbindungen zulassen" gesetzt.

    ich habe dies nun auf "Verbindungen in der VPN Firewall Filtern" gesetzt und nun funktioniert alles bestens.

    Ich kann mir zwar immer noch nicht erklären warum jetzt wo es durch die FW läuft funktioniert und direkte Verbindungen nicht geklappt haben, aber wenn der Traffic nun gefiltert werden kann umso besser.

    Dann kann ich auch endlich die VPN-Firewall aktivieren und konfigurieren.


    Gruß Michael