Endian 2.5.1 eigenartige Ausfälle

  • Hallo Sabine,


    ein vernünftiges Betriebssystem, und das ist Linux ja eigentlich, friert auch bei 100% noch nicht ein. Sonst würden die Rechner der Theoretischen Chemie bei uns ständig einfrieren, bei den Lasten, die die da drauf geben.
    Es ist eher anzunehmen, dass das System mit einer der jetzt abgeschalteten Optionen nicht zurecht kommt und die CPU beschäftigt. Das könnte dann wirklich die Ursache für das Einfrieren sein.


    Gruß, Knut

    Institut für Physikalische und Theoretische Chemie
    Uni Bonn

  • Ich habe das schon mehr als einmal erlebt das die Endian bei voller Prozessorlast einfach stehen bleibt . . . und nichts mehr geht . . .


    Neuinstallation auf schneller Hardware und einspielen der Sicherung, und schon lief alles wie geschmiert . .

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final

  • Hallo,
    wenn ich nach einem Absturz und Neustart die CPU-Auslastung ansehe, so sieht es auch bei mir etwa so aus: studenlang ca. 10 % und dann plötzlich "Null" bis zum nächsten Neustart. Ich mache jetzt einen Versuch, wie Knut, ACPI abzuschalten.
    Suspendmodi und Hyperthreading kann ich in meinem Bios leider nicht finden.
    Wollen wir mal schauen.

  • Hallo Sabine,
    es handelt sich um ein Mini-ITX Motherboard Jetway 7F21G2ES-LF mit VIA Eden 1.2GHz Processor mit VIA CN700 + 8237RP Chipset und 1GB Memory
    beziehungsweise zum Test auch um ein Mini-ITX Jetway 7F21G5D-OC-LF 1,5Ghz mit VIA C7 und Eden (V4) Prozessoren mit VIA CN700 + VT8237RP Chipset und 1GB Memory
    jeweils mit einem sog. Daugthterboard Jetway Adapter 3x10/100 Lan.
    Wieviel Rechner daran hängen? Im Moment gar keine. Alle LAN-Inteface sind ohne Verbindung. Das war natürlich nicht immer so - zunächst hatte ich den Fehler mit anhängenden Rechnern festgestellt.
    Zum Testen installiere ich einfach Endian 2.5.1 und ein zuvor erstelltes Backup und schaue mir auf einem Monitor die Ausgabe an. Solange sich beim Drücken auf "Return" da noch was ändert, lebt das System noch. Doch ich brauche nur einige Stunden (manchmal sogar Tage) zu warten, dann rührt sich nichts mehr, es hilft nur noch der Restart-Knopf.
    Wie schon zuvor erwähnt, habe ich auf gleichartigen Systemen schon jahrelang Version 2.3 stabil am Laufen, teilweise mit über 50 daran hängenden Rechnern.
    Der Fehler schein mir erst mit Version 2.5.0 entstanden zu sein.


    Gruß Reinhold

  • Die Hardware ist schon sehr unterdimensioniert . . . . das reicht nicht mal für eine 6000 Leitung . . .


    Kann halt auch gut sein das dein Lan- Adapter nicht mit der Endian will . . .
    Ich habe einige 2.5.1 am laufen und nirgendwo ausfälle . . . wenn nicht gehe doch wieder auf die 2.3 zurück . .

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final

  • Von 2.3 bin will ich weg, da diese Version die "Fixed Leases" im DHCP nicht unterstützt. Man kann den Punkt zwar ankreuzen, aber er funktioniert nicht. Deswegen die Version 2.4.1 als Ziel. Weiß jemand, ob es da funktioniert?

  • So, ich habe jetzt 2 Versionen ohne Ausfälle am Laufen, die beide die "Nur fixed Leases" im DHCP beherrschen:
    Einmal Version 2.4.1 mit meinem alten Motherbord Jetway 7F21G2ES-LF (1,2 GHz, VIA Prozessor) und
    einmal Version 2.5.1 mite einem neuen Motherboad Jetway JNF9D-2550-LF (1,86 GHZ Intel Prozessor
    warum das so ist, ist mir immer noch nicht ganz klar. Aber damit kann ich leben.


    Reinhold

  • Hi Leute!


    Wir hatten (und haben) ähnliche Probleme mit unserer Endian UTM Mini Wifi 2.5-0 ( Linux version 2.6.32.43-57.e49.armv5tel (root@buildsrv-02) (gcc version 4.1.2 20070626 (Red Hat 4.1.2-13)) #1 Mon Nov 12 10:32:34 EST 2012 ; Endian Firewall Appliance release 2.5-0 (Deployset #0) ).
    Ein Script, welches 1/4-stündlich das Free (real) Memory in einen Log schreibt zeigt, dass dieses kontinuierlich abnimmt.
    Es kam dann vor, dass die Appliance sehr langsam lief, ja sogar nicht mehr reagierte. Die Power-off/-on Option war dann unumgänglich.
    Es kam auch vor, dass die Mini einfach selber re-bootet hat.
    Der letzte (Feb 14 20:15:52) von Endian selber durchgeführte Update hat das Problem nicht gelöst, allenfalls etwas verkleinert.
    Nach ca. 7 Tagen ist die Mini auf >83%. Vorsorglich re-botten wir sie dann, um den Tagesbetrieb nicht zu gefährden.
    Für mich sieht das nach einem klassischen "Memory Leak" aus und klar, dessen Ursache ist nicht einfach zu identifizieren.
    Bis jetzt wurde dies auch von Endian (noch) nicht bestätigt.
    Leider scheint in dieser Sache nichts voran zu gehen - recht schlimm für eine kommerziell lizenzierte und unter Wartung stehende Firewall ... meiner Meinung nach jedenfalls.


    Was ich seit längerer Zeit vermute ist, dass der Hotspot resp., damit zusammenhängend die ganzen Radius Prozesse (bis zu 21 !) eine grosse Rolle spielen. Ich habe jetzt den Hotspot angeschaltet und beobachte weiter. Jedenfalsl: Alle Radius Prozesse bis auf 1 sind weg.


    Es würde mich sehr interessieren, ob jemand von Euch auch solche Beobachtungen gemacht hat.


    Besten Dank und Grüsse.
    Dan