Mehrere IP´s auf ROT / Port forwarding

  • Hallo zusammen,


    habe hier schon viel zu dem Thema port forwarding gelesen, aber leider führte keine der beschriebenen Lösungen zum Erfolg.


    Hier meine Konfiguration:


    Ich habe insgesamt 5 IP´s aus dem gleichen Netz auf die rote Schnittstelle gebunden.
    Die ist an einem Netzbetreiber-Router angeschlossen.


    Mein Problem ist nun folgendes:
    Ich habe mehrere Webserver, die mit unterschiedlichen Domänen an diese IP´s gebunden sind.
    Ich möchte nun die 2. und 3. IP an unterschiedliche Server in grünen Netz bzw. in der DMZ weiterleiten.


    Leider funktioniert das Porforwarding nur mit der 1. IP. Die anderen IP´s sind nicht erreichbar.


    PS: Endian ist Version 2.4, 2.5.1 tuts auch nicht - schon getestet.

  • Hallo.
    Du kannst jeden Port nur einmal Weiterleiten !
    Also nur ein mal den Port 80 auf Port 80 vom ersten Server.
    Für den zweiten Server nimmst du Port 81 und leitest den auf Port 80 und die IP des zweiten Servers weiter.
    Für den dritten Server nimmst du Port 82 und leitest den auf Port 80 und die IP des dritten Servers weiter
    Um auf den zweiten Server zu kommen gibst du die IP oder deinen Dyndns Namen ein gefolgt von :81 ( für Port 81 ) ein..
    Um auf den dritten Server zu kommen gibst du die IP oder deinen Dyndns Namen ein gefolgt von :82 ( für Port 82 ) ein..
    Jetzt kommst du auf alle Server . . . 8-)


    Gruß Sabine

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final

  • Hallo Sabine,


    an diese Möglichkeit habe ich auch schon gedacht - ist nur irgendwie am Sinn von mehreren IP's vorbeigedacht.


    Also ich möchte IP1 an eine interne IP z.b. 192.168.1.101 weiterleiten.
    IP2 an z.B. an 192.168.1.102
    IP3 an z.B. an 192.168.1.103


    Was ich auch schon probiert habe, ist folgendes: auf der .102 läuft zusätzlich ein SMTP, dieser ist auch nicht über port 25 erreichbar, trotz portforwarding. wenn ich den allerdings mit der 1.IP forwarde, dann funktioniert es.


    Warum ist das portforwarding nur für die 1. IP möglich?


    Eine andere Möglichkeit wäre es über eine zweite Netzwerkkarte an den Router anzuschließen.
    Dann verbiedet mir aber endian diese als uplink einzurichten, da die dann im gleichen Netzbereich liegen würde - so auch natürlich sinnfrei.


    Gruß


    Arne

  • Moin,

    Zitat

    Ich habe insgesamt 5 IP´s aus dem gleichen Netz auf die rote Schnittstelle gebunden.
    Die ist an einem Netzbetreiber-Router angeschlossen.


    Erkläre mir doch mal wie das Szenario bei dir aussieht . . .



    Zitat

    Warum ist das Portforwarding nur für die 1. IP möglich?


    Das sollte auf alle IP`s gehen



    Warum hast die Webserver im Grünen Netz stehen ?
    Bau doch noch zwei Netzwerkkarten ein und stelle einen Server in Orange und einen in das Blaue Netz . .


    Gruß Sabine

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final

  • Ps.

    Zitat

    Eine andere Möglichkeit wäre es über eine zweite Netzwerkkarte an den Router anzuschließen.
    Dann verbiedet mir aber endian diese als uplink einzurichten, da die dann im gleichen Netzbereich liegen würde - so auch natürlich sinnfrei.


    Zwei Netzwerkkarten im gleichen Bereich geht natürlich nicht . . . du kannst ja auch nicht 2 Rechner auf den gleiche Switch- Port stecken . .

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final

  • Guten morgen,


    Zitat von "Sabine"

    Erkläre mir doch mal wie das Szenario bei dir aussieht . . .


    Also: Ich habe vom netzbetreiber einen Router da stehen, wo ich isgesamt 5 IP's drauf hab.
    Dieser hat ein Switch eingebaut, woran ich die rote Schnittstelle angeschlossen hab.


    Mein Scenario sieht genau so aus:
    https://endian.zendesk.com/ent…-port-forward-basic-setup


    Das rote Interface ist somit als Ethernet static und dann wie hier eingerichtet:
    https://endian.zendesk.com/att…e=media_1295469370723.png


    1. IP unter IP Address, Network Mask /29, - wie im bisherigen Router auch -
    2. 3. 4. u. 5. IP/29 unter additional addresses eingegeben. Als Gateway die IP vom Netzbetreiber-Router.


    beim port forwarding tauchen die unterschiedlichen IP's auf rot auch unter Uplink-Ip auf wie hier:
    https://endian.zendesk.com/att…e=media_1300818823400.png


    Zitat von "Sabine"

    Das sollte auf alle IP`s gehen


    Genau das ist mein Problem! Es funktioniert nur mit der 1. IP!


    Zitat von "Sabine"

    Warum hast die Webserver im Grünen Netz stehen ?
    Bau doch noch zwei Netzwerkkarten ein und stelle einen Server in Orange und einen in das Blaue Netz . .


    Das soll auch später so sein, nur wollte ich nicht direkt das ganze Netz zum testen umbauen.


    Zitat von "Sabine"

    Zwei Netzwerkkarten im gleichen Bereich geht natürlich nicht . . .


    Das würde aber gerade im grünen oder orangen Netz Sinn machen - z.B. für loadbalancing. Ist aber (noch) nicht meine Intension.


    Grüße


    Arne

  • Load Balancing geht mit der Endian nicht . . . Failover kannst du ach nicht machen weil da ja nur einen Zugang hast.


    Portweiterleitung von Z.b. 200.150.10.2 auf 192.168.1.102 sollte gehen und dann von 200.150.10.2 auf 192.168.1.103 sollte auch gehen.
    Wenn das feste IP`s sind solltest du auch im Browser einmal die 200.150.10.2 und die 200.150.10.3 aufrufen können und auf die jeweiligen Web Server kommen


    Wie sieht es mit einen Ping auf deine IP`s aus ?
    Wenn die Portweiterleitung nicht funktioniert, was sagen dann die Firewall Logs ?


    Gruß Sabine

    EFW Version im Einsatz:
    2 x Endian UTM Enterprise Software Appliance 3.0.5
    1 x Endian Community 3.2.4
    2 x 2.5.1
    8 x 2.2 Final

  • Habe des Rätsels Lösung gefunden:


    Genereller Denkfehler:


    Der Gateway des Webservers sollte natürlich auf auf die Endian zeigen... :oops:


    Zusätzlich sollte man unter Source-NAT dafür sorgen, das nach aussen hin die richtige IP maskiert wird.


    Trotz dem Danke für die Hilfe.


    Gruß


    Arne