Sicherung Samba Windows 7

  • Halli Hallo efw Community


    ich habe leider wieder ein Problem...
    Ich möchte eine tägliche geplante Datensicherung der Endian erstellen, diese dann in einem Verzeichnis kopieren, von Windows 7 Pro 64bit über Aufgabenplanung abholen und diese dann wegsichern. *lufthol*
    ich scheitere leider schon daran von Windows aus auf die Freigabe zuzugreifen. Ich bin dieser Anleitung schon gefolgt:

    Quote

    Leider hat dieses nicht den gewünschten Erfolg gebracht. Meine Vorgehensweise war schon wie Folgt:


    nano /etc/samba/smb.conf


    testparm


    hab natürlich noch den Ordner /tmp/share erstellt und ihm die Rechte mit chmod 777 gegeben. Dann direkt im Windows 7 versucht drauf zuzugreifen mit \\192.168.1.2 Doch leider kommt dazu ein Anmeldebildschirm. Nach laaaaaangen googlen hab ich dann erst die Schuld auf Windows 7 geschoben, hab dazu ein paar Sachen gefunden und diese ausgeführt:

    Code
    1. HKLM\System\CCS\Services\LanmanWorkstation\Parameters
    2. DWORD DomainCompatibilityMode = 1
    3. DWORD DNSNameResolutionRequired = 0
    4. Start -> Ausführen -> secpol.msc
    5. Sicherheitseinstellungen -> Lokale Richtlinien -> Sicherheitsoptionen -> Netzwerksicherheit: LAN-Manager-Authentifizierungsebene 'LM- und NTLM-Antworten senden (NTLMv2-Sitzungssicherheit verwenden) <-- und andere ausprobiert
    6. Netzwerksicherheit: Minimale Sitzungssicherheit für NTML-SSP-basierte Clients (einschließlich sicherer RPC-Server) '128-bit-Verschlüsselung erfordern' <--- Hacken entfernen


    Hat leider alles nicht funktioniert, dieses Anmeldefenster kommt immer wieder... Da ich dann die Schnau.. voll hatte, hab ich dann einfach testweise Debian Squeeze installiert, Samba installiert, genau so kkonfiguriert wie oben beschrieben. Es hat sofort funktioniert. Also dachte ich mir, ich schieb die Schuld dann doch vorerst zur Endian :?


    Also ich bin jetzt planlos und hoffe das mir hier jemand helfen kann.
    Liegt der Fehler schon dort, dass testparm kleine Fehler ausspuckt?
    Kann ich eigentlich das Samba in der Endian updaten?
    Kann ich die Freigabe nur mit Benutzerrechten benutzen?
    Wie könnte ich sonst meine Aufgabe wie oben beschrieben lösen, falls es mit Samba nicht funktioniert?


    Hoffe das hat jetzt keinen abgeschreckt zu antworten :-)


    Wünsche noch einen schönen Feiertag
    Dave

  • Hallo


    Ich hab mal auf einem testserver eine minimal smb.conf erstellt und getestet ohne in den windows clients etwas rumzuspielen
    du musst nur die workgroup von xxx auf deine ändern bei der freigabe ist kein passwortschutz mehr vorhanden.



    Quote

    Wünsche noch einen schönen Feiertag


    wieso bin ich auf Arbeit :nerv:


    schönen Arbeitstag noch :evil::evil:


    Alex

  • Hallo nort,


    Vielen Dank für die Antwort, aber leider gab es nicht den gewünschten erfolg. Ich habe mir heute noch mal den Threat von dektar1 durchgelesen und ffischer hat gesagt das man Ports noch freischalten muss:

    Quote from &quot;ffischer&quot;

    3. Neue Systemregel in er Firewall hinzugefügt ( siehe Anhang ) und diese Übernommen


    Den Anhang hab ich nicht gefunden, aber dektra1 hats ja noch mal wiederholt

    Quote from &quot;dektra1&quot;

    Im Endian Webinterface hab ich unter Firewall -> Systemzugriff die Ports 113 sowie 137-139 von Quelladresse (alle) und Schnittstelle (grün) freigegeben. Funktioniert super.


    Habs gemacht und hat dann super funktioniert. War wohl gestern doch schon zu spät, bzw. heute zu früh :bug: Funktioniert auch mit meiner smb.conf.

    Code
    1. [global]
    2. security = share
    3. workgroup = WORKGROUP
    4. [Sicherung]
    5. path = /var/backups
    6. read only = no
    7. guest ok = yes
    8. create mask = 777


    Somit kann ich jetzt die Backups kopieren/ausschneiden und wegarchivieren.


    Dennoch hab ich jetzt noch ein Problem. Und zwar kann ich ich samba immer noch nicht beim booten automatisch starten. Wie von ffischer beschrieben habe ich die Datei /etc/rc.d/start/99sambastart mit den Rechten 755 angelegt. Inhalt:

    Shell-Script
    1. #!/bin/sh
    2. /etc/init.d/smb start
    3. exit 0

    doch wird sie beim booten anscheinend ignoriert. Wenn ich es manuel starte mit

    Quote

    /etc/rc.d/start/99sambastart start

    funktioniert das aber...
    Ich hoffe dabei kann mir auch noch geholfen werden :-)


    Quote from &quot;nort&quot;

    wieso bin ich auf Arbeit :nerv:


    schönen Arbeitstag noch :evil: :evil:


    dann erwähne ich mal nicht, das ich morgen auch noch einen Brückentag habe :-) ups habs doch getan


    Gruß
    Dave